Обновление PostgreSQL 10.4, 9.6.9, 9.5.13, 9.4.18 и 9.3.23

Сформированы корректирующие обновления для всех поддерживаемых веток PostgreSQL: 10.4, 9.6.9, 9.5.13, 9.4.18 и 9.3.23, в которых представлена порция исправлений ошибок. Выпуск обновлений для ветки 9.3 продлится до сентября 2018 г., 9.4 до декабря 2019 г., 9.5 до января 2021 г., 9.6 — до сентября 2021 года, 10 — до октября 2022 года.

В обновлении устранена уязвимость (CVE-2018-1115), связанная с предоставлением общих привилегий (вместо привязки к администратору) для вызова функции pg_logfile_rotate(), устаревшего варианта pg_rotate_logfile() из contrib/adminpack. Уязвимость позволяет любому пользователю PostgreSQL инициировать ротацию лога, в случае если установлен adminpack. Для устранения уязвимости после установки обновления пользователям adminpack следует выполнить «ALTER EXTENSION adminpack UPDATE» для каждой БД.

Кроме того, исправлено более 50 ошибок, например, устранена утечка памяти при выполнении операций слияния хэшей, решены проблемы с крахами при использовании «GROUPING SET», оптимизирована установка блокировок при выполнении autovacuum. Много исправлений связано с параллельным выполнением операций, в том числе устранена взаимная блокировка, возникающая при определённом использовании «CREATE INDEX CONCURRENTLY».

Источник.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.