Выпуск файлового менеджера Double Commander 0.9.0

Доступна новая версия двухпанельного файлового менеджера Double Commander 0.9.0, пытающегося повторить функциональность Total Commander и обеспечить совместимость с его плагинами. Предлагается три варианта интерфейса пользователя — на базе GTK2, Qt4 и Qt5. Код доступен под лицензией GPLv2.

Из особенностей Double Commander можно отметить выполнение всех операций в фоновом режиме, поддержку переименования группы файлов по маске, интерфейс на базе вкладок, двухпанельный режим с вертикальным или горизонтальным размещением панелей, встроенный текстовый редактор с подсветкой синтаксиса, работа с архивами как с виртуальными директориями, расширенные средства поиска, настраиваемая панель, поддержка плагинов Total Commander в форматах WCX, WDX и WLX, функция ведения лога файловых операций.

Основные новшества Double Commander 0.9.0:

  • Сортировка по столбцам с данными от контентных плагинов (отображают дополнительные свойства файлов в списке, такие как mp3-теги и данные из EXIF);
  • В выводе плагинов файловой системы (предоставляют доступ к различным ресурсам как к файловой системе) теперь можно добавлять пользовательские столбцы;
  • Добавлена поддержка вычисления и проверки хэшей BLAKE2b и BLAKE2bp;
  • C помощью инструкций SSSE3 (x86_64) ускорена работа с хэшами SHA256 / SHA512, а с помощью инструкций SSE2 (x86_64) ускорена работа с хэшами BLAKE2s и BLAKE2sp;
  • В плагин для работы с FTP добавлена поддержка протокола SSH + SCP, возможность аутентификации с открытым ключом (SSH), поддержка прокси (SOCKS 4/5, HTTP CONNECT) и режим выполнения команд из командной строки (SSH);
  • В системе синхронизации каталогов предоставлена возможность выбора элементов в файловой панели и синхронизации только этих выбранных элементов;
  • В плагин SevenZip добавлена поддержка внешних кодеков (Windows);
  • Обеспечено отображение процессов, которые блокируют операцию удаления файла (Windows)
  • Добавлен тест для измерения производительности хэширования;
  • Обеспечена поддержка выпусков Lua 5.2 и 5.3, для кода на Lua добавлена библиотека для работы с UTF-8.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.