Обновление PostgreSQL 11.1, 10.6, 9.6.11, 9.5.15, 9.4.20 и 9.3.25

Сформированы корректирующие обновления для всех поддерживаемых веток PostgreSQL: 11.1, 10.6, 9.6.11, 9.5.15, 9.4.20 и 9.3.25, в которых представлена порция исправлений ошибок. Выпуск обновлений для ветки 9.4 продлится до декабря 2019 г., 9.5 до января 2021 г., 9.6 — до сентября 2021 года, 10 — до октября 2022 года, 11 — до ноября 2023 года. Поддержка ветки 9.3 прекращена, 9.3.25 стал последним выпуском.

В новых версиях устранены накопившиеся ошибки и устранена одна уязвимость (CVE-2018-16850), которая может использоваться для выполнения произвольых SQL-конструкций с привилегиями суперпользователя в момент запуска утилиты pg_upgrade или при сохранении или загрузке дампов утилитой pg_dump. Атака производится через создание некорректных определений «CREATE TRIGGER … REFERENCING» и может быть совершена пользователем СУБД с правом выполнения операции «CREATE».

Источник.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.