Обновление PostgreSQL 10.2, 9.6.7, 9.5.11, 9.4.16 и 9.3.21

Сформированы корректирующие обновления для всех поддерживаемых веток PostgreSQL: 10.2, 9.6.7, 9.5.11, 9.4.16 и 9.3.21, в которых представлена порция исправлений ошибок. Выпуск обновлений для ветки 9.3 продлится до сентября 2018 г., 9.4 до декабря 2019 г., 9.5 до января 2021 г., 9.6 — до сентября 2021 года, 10 — до октября 2022 года.

В обновлении устранено более 60 ошибок, в том числе улучшена работа параллельных запросов (устранена взаимная блокировка при одновременном выполнении «CREATE INDEX CONCURRENTLY») и репликации (налажена работа триггеров при логической репликации и устранено состояние гонки при удалении источника репликации), а также решены проблемы в коде VACUUM, GIN-индексов и hash-индексов, которые потенциально могли привести к повреждению данных. Устранены две уязвимости:

  • CVE-2018-1052 — некорректная обработка ключей секционирования, содержащих несколько выражений, позволявшая получить содержимое произвольных областей памяти рабочего процесса;
  • CVE-2018-1053 — создание в процессе работы pg_upgrade временных файлов, доступных всем на чтение (во временных файлах могут содержаться конфиденциальные данные, такие как поля с паролями).

Источник.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.